Home / Download / Yaseen Audio

Yaseen Audio

This software is intended for users with J2ME MIDP 2.0 enabled phones with MMAPI extensions such as S60 phones (6680 etc.), S80 (9300, 9500), S90, and UIQ 2.1+ e.g. Sony Walkman/Cybershot Phones (K700, K750, K800 etc). It requires Java support for at least 1Mb Java/Jar files & heap memory (see your phone manufacturer to check minimum heap is 1Mb or above).

Yaseen Audio